TELEGRAF: No Data Flowing: E! [agent] Failed to connect to ... error was 'could not create Wavefront Sender for the provided url'

This article applies to:

 Onboarding, TAS Integration

• Product edition: all versions.

• Feature Category: Integrations, Telegraf, Proxy 

 

Problem Description:

After setting up the Proxy and Telegraf agent on an Ops Manager environment, data is not sent and by reviewing the Telegraf's logs you find something similar to this:

2023-03-06T14:07:28Z E! [agent] Failed to connect to [outputs.wavefront::wavefront-pipeline-1], retrying in 15s, error was 'could not create Wavefront Sender for the provided url'
2023-03-06T14:07:43Z E! [telegraf] Error running agent: connecting output outputs.wavefront::wavefront-pipeline-1: error connecting to output "outputs.wavefront::wavefront-pipeline-1": could not create Wavefront Sender for the provided url

 

Cause:

The Telegraf agent is attempting to connect using the custom url provided under Advanced Options but this connection is not successful. So the agent will keep trying every 15 seconds.

 

Resolution:

The reason behind this error message is a wrongly typed or invalid URL on the Custom Proxy URL field, which will show up once you enable the Telegraf's Advanced Options.

If Advanced Options is enabled, the Custom Proxy URL and Custom Proxy Port must be properly filled.

 

For example,

  • Please consider if the custom proxy URL does or does not require an http(s) as part of the URL.
  • Additionally, unless explicitly changed, the default's Proxy port would be 2878.

 

See also:

Configure the Tile’s Telegraf Instance to Send Traffic to the Load Balancer

 

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk